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QUALITY ANALYSIS IN VIRTUAL BUILD MODULE

'1. WORKSPACE

Virtual Build works on the concept of Workspace, which includes assigning one or multiple Routings
and CAD files. CAD files are not a mandatory requirement to create a workspace.

g Virtual Build
1.1 Open the Assembly Planner application, and navigate to Virtual Build Library
1.2 Click on Workspaces from the ribbon.

Home Process Consumption Quality Analysis CAD Viewer
> ~ a E
Y o=
Workspaces Reload Close Panel Restore
Workspace Workspace Visbility ¥ = Default Layout
Workspaces Panel Visibility

1.3.1 Open existing Workspace

Select the Workspace from the available list of Workspaces (left).

Respective routing and CAD file details are shown on the right side.

Click Open Workspace from the Workspace Management ribbon> Application will navigate
the user to the Virtual Build Module.

File Edit Tools Helg

Q) Back ) Forward
Library

-
#? Virtual Buid
¢ 5& S

£ o

2? Activity

& Workspaces o X
Workspace Management
>

& Search Type | Default (AN)

Search

Open Workspace || Edit Workspace Delete

Workspace

New Workspace Search Criteria

Workspaces Workspace Search

Available Workspaces Workspace Details

Find Assigned Routings
L3
Sanjay Thangavel »  6077_D

Sanjay Thangavel

Assigned CAD Files

» 6077.2p 4
dministrator

Administrator

jaryd

Administrator

Data Momt

example of notification

todd

Admin Tools

jent PFMEA  Control Plan

lev) | Administrator | 12.15.2.0
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1.3.2 Create new Workspace

a.

&) Create New Workspace

Navigate to New Workspace> Add Routings

Define Workspace Detais

Save Workspace

b.

Workspace Name:

-
i zym
AddRoutings ~ Add CAD
e

Workspace Name Define Routings And CAD Files

Select the required Routing to be added to the Workspace and click the add selected
button.

o Users can select one or more Routings.

If a new Routing needs to be added, right-click on the Routing list> Click Add New>
Update the Routing details> Click OK> Refresh the Routing list> Now, new Routing

will be available for the workspace selection.

If the user needs to add CAD files, navigate to Complete Selections> Add CAD Files

CAD Files are not mandatory to create a workspace or to work in Virtual Build module.

Users can select more than one CAD files.

Clear
Form

& Create New Workspace o X
Define Workspace Details
v X
Workspace Name: | 6077_Demo
Complete Clear
Selections Form
Save Workspace Workspace Name Complete
Routing Search add Seected mlpp Routing Assignments
% & 3 ~[a Y = - = e e a0c oD -
Routing Type: ) » x 6077_Demo M PPO3 CheckedOut
PlantiD PPO3 v
jis] Routing Type Description Plan
2 00004317 Ea
}, 00004755 Autoslideab F
i 01-HT-Finish M Head Traller Finish b F
Jx 37.391.000 M DUCATO DESTRO F
)x 37.391.000 REV1 M DUCATO DESTRO F
2 6077 Sanjay M F
2 6077.1 M e
R4¥6077_Demo M
B 6077_PA M Process Auth. £
c. Give a Workspace name.
d. Click Create New Workspace> Application will take the user to the Virtual Build module.
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2. NAVIGATING IN VIRTUAL BUILD

a. Process Tree (Left): Encompasses Routing, Operations/ Work Stations, activities, and detailed
work steps.

b. Process Panels (Right).

c. Panel Docking: Each panel can be dragged and docked according to user comfort. Very useful

when the user has multiple screens to work with.

& Assembly Planner a x
File Edit Tools Help

D Back ) Forward [

Library m Process Consumption Qualty Analysis CAD Viewer [i]
(mmr\erl > o m B E
Bl nss | e e
“akwnrg = .
.‘&Ope-a:mﬂ

, - Model T
wmm d odel Tree

] Node Properties @
‘\\“' Resource T = o _

Pant
3 Madel
j Option

9] eco Process Tree

CAD
[ &

y
“@ peviation

Panel Restort
Visibikity Defauit Layout

Process Viewer

@ uco

&

) pashooard

Modules

PFEP

Deta Rt Dockable Panels

Tools ] Consumption = Viewer = Operation ActivityList = Properties CustomField Media Time WorkStep | Resource = Model Option  EditModel-.. = Document = PFMEA | Control Plar

PPO3(Dev) Administrator | 12.15.2.0

d. Ribbon Control
o Home
= Panel Visibility - Users can turn the visible panels on/off.

= Restore Default Layout — Takes the user back to the system's default view.
o Process
= Actions - Process check in/out.
= Add/ Remove - Add process data (Operation/ Activity/ Workstep) based on
process tree selection.
= Move/ Copy - Move or copy the selected process.
o Quality Analysis
= Manage Revisions - Revisions library for the selected sheet/ process.
= Import/ Copy - For bulk upload of QA data (Note: Templates need to be
defined for this function to work, contact ProPlanner support).
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= Reports - QA Report (WYSIWYG), Revision comparison (highlights
adds/changes between selected revisions).

= Header Layout - Customize view for header layout.

= Load Default View - This takes the user back to the company-specific default
view of QA sheets. (Note: All the customizations done to the QA sheets will be

gone)

3. PROCESS AUTHORING IN VIRTUAL BUILD

Quality analysis (PFMEA and Control Plans) can be performed on Routing, Operation, and Activity
levels. For the users to start entering quality-related data, their corresponding process must be
defined.

3.1 Routing
a. Already defined when creating a workspace.
3.2 Operation

a. Select the Routing from the process tree (Routing must be checked out).

& Assembly Planner
File Edit Tools Help

O Back ) Forward [

Library Home Process Consumption CAD Viewer Qualty Analysis Media
Cal o =)
Companent
5 MY - + =
&_ e alna Save :1:';:,"(' \;h:‘—. indo Check Out  Chedk add Hstory
\ Actions Move e
¥ Routing
' Process Operation List
Status D . OpSeaNo  ~ EffectiveFromDate | ~ EffectiveToDate  ~ Description | +
00005165 1.00 17242023 1273172055 Pivot Head

. Assembly
00005166 Base Assembly
00005167

2
3
4 00005244
5
6

Inspection
Test

b. Adding/ Editing Operations

i Navigate to process ribbon> Add Operation> Update the Operation details> Ok (OR)

ii. Open Operations list panel> update the Operations list> Click save

Key Fields: OpSeqNo, Description, Workstation, and Effective From/To Dates
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3.3 Activity

QUALITY ANALYSIS

a. Select the required Operation from the process tree (Selected Operation must be checked out).

& Assembly Planner

File Edit Tools Help
o Back o Forward d
Library Home Process Consumption CAD Viewer Qualty Analysis Media
BEA o moonent L] =]
B Y -« + X I P .
Save Process Check UndoCheckOut Check [JAGAIN Remove Movelp MoveDown MoveTo Copy Autobuid re History
Virtual Buid Fiter  Outv v In v = v Model-Option
4 Actions Add New Activity Move / Copy Group View
Py e ,
Process Add Existing Activity '|ty List
& Operation
- Status _Is Reused D [+ |ohOF-| ActSeaNo || Description v  EfiectveFromDate |v| EfiectiveToDate |+
P il 1 00005171 1:00-70C 1.00 Stick Decals 1242023 123172055
Activity ]
= 2 00005172 1:00-70C 2.00 Install jaw latch 1242023 12/31/2055
o e 3 00005173 1:00-70C 3.00 Install jaw pin 12472023 1213172055
k@ Resource Y= "0e - 7 00005174 1:00-70¢ 4,00 Secure latch to 12472023 1213172055
v 4 6077_Demo pivot head
4 Plant = 5 00005175 1:00-70C 5.00 Secure the locking  1/24/2023 12/31/2055
T A ’ v 4% 00005165 PivotHead Assembly 1 a bar
i > & oo » dl ® 00005176  1.00-70C 6.00 Install safety lock 17242023 1273172055
c Model dl 7 00005177 1:00-70C 7.00 Install locking bar 123112055

> & oo

b. Adding/ Editing Activities

12412023
with pivot head

i. Navigate to the process ribbon> Add New Activity> Update the Activity details> Ok (OR)

Open Activity list panel> Add/ update the activity list> Click save

Key Fields: ActSegNo, Description, and Effective From/To Dates

4. CUSTOM VIEW FUNCTIONS (QA MODULE)

4.1 Header Layout Customize view

a.

PFMEA
Header Data

Company Name & Customize Layout
Confidentiality Level O Reset Layout

Ciietrmar Nama

Right-click on the QA sheet header data or select Header layout menu button from QA ribbon.

b. Customize header layout popup will open, where various restructuring functions can be

performed.

PFMEA

Customize Header Layout

e »
i

Header Data

Layout Items | Hidden Items
v f Root
Company Name

B Confidentiality Level
B Customer Name
[l PFMEA ID Number
Bl Manufacturing Location
B Model Year(s) / Program(s;
B Process Responsibility
[l PFMEA Revision Date
[l PFVEA Start Date
B subject
B Cross-Functional Team

View AIAG & VDA PFMEA

Structy

C.

2
@
O

As

X

C Reset Layout

Hide Customization Form
Best Fit

Size Constraints

Reset Layout

Rename

Hide Text

Text Position >

Users can also restructure the layout using drag and drop.

Proplanner
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4.2 QA Sheet Customize view

a. Right-click> Customize view on the QA Sheet that needed to be customized.
b. Columns tab:
i Fields can be made hidden and visible, and their sequence can be altered
ii. Fields can be clustered into a group or multiple groups.
o Select a field or multiple fields that need to be grouped.
o Right-click on the visible fields section, where users can add the selected fields to
a group.

(Note: A group can only be deleted and cannot be removed)

Customize View

View

Curent View: |AIAG & VDA PFMEA v Add Remove

Columns | Properties

Hidden Fields: Visible Fields:
Name Name Width Key
P - Activity|Description » E+istructure Analysis (Ste.... | N "
- Activity |ID - ProcessItem 152 Add to Group...
- Classification - ProcessStep 132 Remove from Group
- Operation|ID - ProcessWorkElement 143
- UID &+ Function Analysis (Ste... Delete Group
- RequirementOfProcessItem - FunctionOfProcess... 120 Edit Group...
- RequirementOfProcessWorkEle... - FunctionOfProcess... 120 =
- RequirementOfProcessStep - FunctionOfProcess... 120
- Routing [ID =} Failure Analysis (Step 4)
- RPN Add -> - FailureEffects 188
- RPN2 - Severity 50
.. SpecialCharacteristics < Hemove - FailureMode 120 ¢
- SpedalCharacteristics2 - FailureCause 120
-]~ Risk Analysis (Step 5)
- CurrControlPreven... 120
- Occurrence 50
- CurrControlDetection 120
- Detection 50
- ActionPriority 50
- FilterCode 50
=} Optimization (Step 6)
- RecActionPrevention 109
- RecActionDetection 101
- Responsibility 105
- TargetCompletionD... 120
- Status 50 v
Width of the column (in pixels): [_

[ok ] concal || iosl
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c. Properties tab

i Header/ Column properties of the selected group or fields can be edited.
ii. Select a field or multiple fields (left).

iii. Update the properties and click OK, for the customizations to be applied.

Customize View X

View

Cumrent View: | AIAG & VDA PFMEA v Add Remove

Columns | Properties

Visible Fields: Column Header Row Settings
Name Width Key R i e |
ow No: - ow Height:
’E - e
152 Column Header Settings
- ProcessStep 132
Back Color: | [ 230, 230, - Border Color: | 0,0, 0 -
- ProcessWorkElement 143 :
5. Function Analysis (Ste... Fore Color: | Il 0, 0,0 - Border Width: (2
- FunctionOfProcess 120 Font Name: |MicrosoftSansS... ~ Border Sides: |Left -
- FunctionOfProcess 120 e o !
ont Size: . =
- FunctionOfProcess.. 120 L . VASGRex: S| Center
~} Failure Analysis (Step 4) FontStyle: | B I Ul ab HAlignment: |Center -
- FailureEffects 188 r
Word Wrap: Rotation 0
- Severity 50 Angle: L
- FailureMode 120
- FailureCause 120
[0, 255, 2 |
+}- Risk Analysis (Step 5)
- Optimization (Step 6) 0, 0,0
B ab enel
< >

5. CUSTOM FIELD FUNCTIONS (QA MODULE)

5.1 Adding a new custom field

a. Navigate to Admin Tools> Custom Fields Manager> Select the entity where the respective field
is present.
b. Click Add> Update the field properties and click Ok.

c. Restart the application for the changes to get applied.
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File Edit Tools Help

Q) Back ) Forwerd

— Select Entty | QADetais02 -
Modues Custom Field List
Name Display Name DataType  Defoul Vabe  List Name sReadOnly  lsVisble  lsMuline  lgnore in inpot ~
FrER ActonPnonty PEMEA AP nvarchar(50) Yes
ActonProty2 PFMEA AP nvarchar(s0) Yes
Ll ActanTaken Action Taken weh Porte... nvarchar(d(... Yes
Classfication Classfication nwarchar(S0) Yes
Lo Completion Date Completion Date datetime 1/1/1500 Yes
ﬁ — CunControl Detection Cument Detection Control. nvarchar(40. ey
CurControlPrevention  Cusrent Prevertion Cortr.  nvarchar(40
Detection Detection (D) of FC/FAM 1t 0 Add Custom Field *
“ Reles Detection? Detection (D) i ] FeidName: |
FareCause Falure Cause (FC) nvarchar(d0.. :
[B el FailreEffects Faiure Efects (FE) nvarchar40... Display Name: ]
Moo FalreMode Falure Mode (FM) nwarchar(dd Dt Type =
3 Template FierCode Fiter Code (Optional) nvarchar(100) e
{85 Manager FunclionOfProcesstem  Function of the Process | nvarchar{d0) Max Length: 50 S
o FunctonOfProcessSiep  Function of the ProcessS. . nvarchar(d0...
a il FunctionOfProcesaWorkE .. Function of the Process . nvarcharfd0... DetwatVabe: [ ]
Occurence Occurence () of FC nt 0 Lt . S
?,_-Jﬂ Auto Numbering Occurence? Occurence (0) t 0
By Procssston Process kom p—— Er—r—l |
 w ProcessStep Process Step nvarchar(40
U ProcessWork Bement Process Wosk Bement nvarchar(40... [0 Readonly [ Visble [ Mutiine [ Ignore in import
RecActionDetection Detection Action nvarchar(40...
"5;‘:‘,;‘*"' RecActionPreventon Prevention Action nvarchar40 Advanced [ox ]| coal
Remaks Rematks nvarchar(256)
RequirementOifrocesstem Requrement of the Proc  nvarchar(40. T
RequiementOfProcessStep  Requirement of the Proc . nvarchar(40 Yes
RequrementOfFrocess\W. . Fequrement of the Proc . nvarchar(40 Yes
Responsiity Responsibity nvarchar(d0 Yes
RPN RPN nt 0 Yes
RPN2 RPN nt 0 Yes
Sevety Sevedty (S)of FE " 0 Yes
Severty? Sevesity (5) int 0 Yes
Specially Special O mvarchar(100) Yes
SpecilCharacterstica?  Soec Charactersics  nwarchar(100) Yes
Stafus Statun nvarchar(S0) WorkSiepKey Yes .
TamalomelatonNsts  Tamet Complaton Nsta _dstatia 110800 Ve

PPO3(Dev) | Administrator | 12.16.0.0

5.2 Adding dropdown list values to a field

a. Navigate to Data Mgmt > List Management

& Assembly Planner - ] x
File Edit Tools Help

Q) Back ) Forwerd o

Library Lt

Select Lit: ][ A
Modules l:mwm =
MethodOfAcquistion ;

Data Type

List Values we

Descripion B|
PayPort

PFEP CartType Dashboardicon
PFEPColor

PFEPPartPlanRoute
PFEPUnitOfMeasure

B
z
ﬁ,f
[«

NERRURBNEESIESISGRIR IS @ e oo s wn

i m— 121

PPO3(Dev) Admuinistrator | 12.16.0.0

b. Updating existing list values

i. Search for the list, click edit, update the values, save, and restart the application

Proplanner Confidential Page 10
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c. Adding new list
a. Click add, name the list, update the list values sheet, and save.
b. Now, the created list needs to get mapped to a field.
c. Navigate to Admin Tools> Custom Fields Manager> Select the entity where the
respective field is present.
d. Select the field> Edit> List> Select the respective list you created> Click Ok.

e. Restart the application for the changes to get applied.
5.3 Adding Formulas and Conditional Formatting to a field

a. Navigate to Admin Tools> Custom Fields Manager> Select the entity where the respective field
is present.

b. Select the required field> Click edit> Advanced (a new popup window will open).

File Edit Tools Help

D Back ) Forward [

LUibary Select Enity: | QADetais02 v
R Custom Field List
Harme Display Name DataType  Defouk Value  List Name lReadOnly  lsVsble  IsMubine  ignore b mpor
Lisr Action Prionty PFMEA AP nnvarchar(50) Yes
Action Priority2 PFMEA AP nwarchar(S0) Yes
Dutn Mot ActionTaken Action Taken wih Pointe... nvarcharid Yes
P Classication Cassficaton nvarchariS0) Yes
CompletonDate Compietion Date datetime 11171300 Yes
m — CunControlDetection Curment Detection Control nvarchartdl. Yes
CurControlPrevention Currert Prevention Cortr. nwarchar(40. o
Detection Detection 0)of FC/FM it 0 Field Ul Settings Editor %
& Roles Detection2 Detection (D) it 0
FalureCause Faire Cause (FC) rvarchar(dl L= [ Fomia  |[PRODUCTI-@ccusmence~ ~@Severty~ ~@Detecion)
Custom Fields FaiureBects Faiure Effects (FE) nwarchar(40, Display Name: [RPN
FaiureMode Failure Mode (FM) nvarchart40), e i

B rerpiate 1 FiterCode Fater Code (Optond) nvarchar(100) DuaType: 8 .

L | < FunctionOfProcesshem  Function of the Process | nwarchar40 MaxLongh:  [1 : + | EqualTa -0 - 1
— FunctionOiProcessStep  Funcbon ofthe Process5 . nvarchar(4D. - — .
e FunctionOfProcessiiokE. . Functon ofthe Process . nvarchar(dl) Defaul Valve: [0 -

. Oceumence Ocoumence O)ofFC it 0 ™ None . Setween 1 |x |e.. B
# o sdir s Occumence? Occurence (0) int 0 Between #u % =m.
= Ly Processhem Process fem nwarchar(40, Name: Between 1 -
) vortow ProcessSep Process Step fwarcharidD seheme

Process!tiokBement Process Work Blemert  rwarchari2l) [ Readonly [ Visbie [ Jlionare in Inpoe
e e Rlec ActionDetecton Detection Action nvarchar(dl)
P iy RechctionPrevertion  Preverdion Acton rvarcharial, oK Cancel Carcel
Remarks Remarks nvarchar(256)
RequrementOfProcesstem  Requrement of the Proc...  nvarchar(4l. Yes
RequrementOfFrocessStep Requrement of the Proc_  varchar(dl). Yes
RequirementOfProcessW. Regurement of the Proc. nwarchar(40, Yes
Responsbity Responsibity nvarchari40 Yes
RPN RPN nt ] Yes
RPN2 RPN int 0 Yes
Severty Severty (5)of FE it 0 Yes
Severty2 Severty (S) int 0 Yes
ialCh Special Ch nwarchar(100) Yes
SpecialC Special & nwarchar(100) Yes
Satus Status nvarchariS0) Wok StepKey Yes
TargetConpletinDate  Target Completon Date  datetime 1171300 Yes

e
c. Adding Formula
i. In the formula field, type the formula that needs to be added.
ii. Ex: Multiplication formula> PRODUCT(~@FieldNamel~,~@FieldName2~,.....)
iii. Check with ProPlanner support for other formulas.
d. Adding Conditional Formatting
i. Right-click on the conditional formatting space.
ii. Add instance> Fill in the required formatting options.
iii. Click Ok

e. Restart the application for all the changes to be applied.
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6. AUTHORING QA DATA

Authoring QA data to the PFMEA/ Control Plans sheet is very straightforward.

' B - e B © S

Save the data.

Make sure the process entity is checked out.
Open the required QA Panel (PFMEA/ Control Plan).

Fill in the header data if necessary.

Select the respective entity level (Routing/ Op/ Act) from the process tree.

Start populating/ copy-paste/ importing the QA Sheet for the selected process.

& Assembly Planner - o ®
File Edit Tools Help
Q) Back ) Forward
Home Process Consumption CAD Viewer Qualty Analysis Meda 9 -
El D eortview
F'E B @R 8 B v
QA Repart QA Revision Import Copy  Remove Header 4 Load Defauit Views
v Comparison Report - hd Selected v Layouts v
Report Manager Views
£ Process PFMEA Control Plan
______ P Header Data [ Header Data 1
- — CompanyName |PPO3 | PFMEAIDMumber | A54758 | Confidentisity Level | Low:al Internal Employees CoreTesm | QA
T = o Customer Name | Al Customer Engineering Approval Date | 2/28/2023
a ~ ¥ 6077 Demo Key Contact/Phone
\G & VD, - v Manage Revisions Merge R
= Pivot Head Assen = i A PRHEA Revisions: B Qe Rows.
- = == \View: |AIAG Control Plan View | Revisions: - | | Manage Revisions
Sk Decals Failure Analysis (Step 4) Risk Analysis (Step 5)
instal jaw latch 5 s -
g Obtain jaw hook(] Fa-‘ o =
; Insert roll pin (8} Failre Mode (FM)  [Faiure Cause (C)| B! | Failre Bifects FE) |opiciie | S5 jg RPN . .’545;:)'|U Obtain part ofsame size 6077
Station - AT
i Collect secondary hd hd - LTy - - - - “ Install bearing
Combine (C) with Fuel Hole Diameter 50 Diameter 100 big Oversize drill used - 1 i E
- 1 |mm+-02mm wrong dnill selected 3.0000 Debur pin hole 021
Insert latch asses (FN100) 2
> Install 3o pin 2 !O::‘;edr-llvom 2 4 - a 40000 Obtain hook 841376
Se latch CNC Spindle 1 2 14 " A
i eare atch topi | 5 S = 50000 Install roll inA
Seawe the bdiny Manifold loose in 2 2
i- Instal safety lock - fixture - 6 60000 Install roll pin B
[Dvameter too Undersize drill use - 1 1 5 7 A
> 9 00005177 Instal locking bar | 5 amall weong il sclecied 7 7.0000 sl secondartjw [1ACS69
# 00005178 Collect Sthwheel | g Aum:‘f“‘"‘ from 2 4 31 B
0 Base Assembly 7 Drill Wear 1 2 20 ¢
Irspecton 8 10
Test 9 1
10 A 12
‘ » 3 -
-—
+ 0% |IrS =
Con.. | Ve Ope. Act.. Pro Cus. | Meda Tme Wor_ | Res. Mod  Edit . Doc. PFM -——t—
PPO3(Dev) | Administrator | 12.16.0.0
Proplanner Confidential Page 12
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7. QA FUNCTIONS

7.1 Managing Revisions

a.

QUALITY ANALYSIS

QA Module offers revision control for all the processes. Multiple Revisions can be created,

tracked, and analyzed. Only the active revision is editable, and all the prior revisions are saved

as read-only sheets.

revisions can be created and managed.

File Edit Tools Help

Q) Back ) Forwerd [

Home Process Consumption CAD Viewer Quality Analysis Meda
f'E B g0 F B e
~" Comparison Report Selected ~  Layouts
Report Manager Views
E Process PFMEA
Fine Header Data
Company Name | PPO3 PFMEA ID Number | A54798
o A
-]
g DA PFMEA - Revisions - | Manage Revisions
Stick a
Tnstall jaw atch
g Obtain jaw hook( Status PNEI Revisions
E
= 0 o Description Modéied On Modifed By
i - B 3/28/2023 955...  Administrator
[ A 3282023 924.... Administrator
1
] Create New Revision
Fe 2 =
4
i 3 = Revision 1D
i- 4 = Descrption
5 =
=
.| =
7 =
8
C
10
4
Consumption | Viewer = Operationlist Acthitylist Properies CustomField =~ Meda | Time

C.

multiple revisions.

PFMEA
Header Data

Company Name

Customer Name:

View AIAG & VDA PFMEA

In the QA sheet Click Manage Revisions button> this will open the revision library, where the

L]
1
Confidentality Level | Low:Al Interal Employees
Merge Rows Fiter
rsis (Step 4) Risk Analysis (Step 5) =
2 et | F [ Sz
ol B | rmorceve (Tmn) B8 | 35 o | e
- - - Joi R - - r -
big §  Oversizednll used - 2 1 18
wrong dnll selected
3 Oversizednll from 2 4
upplier
CNC Spindle 1 2 %
alignment error
Manifold loose in 2 2
fixture
5 Undersize drill use - i 5
wrong drill selected
3 Undersize dnill from 2 5 24
Cancel supplier <
— 10 Diill Wear 1 2 20
Save Changes Cancel C
-—+—+ w
WorkStep  Resource  Model Opton  Edit Model-Option Document ~ PFMEA

PFMEA ID Number

- | Revisions

{ n | (Select All)

= | Manage Revisiond

Pess tem

A
B

=1

oK Cance e |

The revision dropdown will display the set of available revisions, where users can select one or

Based on the above selection, the QA sheet will display the results. In image below is showing

the QA details for the revisions A and B, where A is the old revision (highlighted in grey - read

only) and B is the current revision. This enables the users to perform before and after

analysis.

Proplanner
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Home Process Consumption CAD Viewer ggaity Analysis Media

| B &g

QAReport  QARevison Import Copy Remove  Header | & LoadDefaultViews
v Comparison v v

) Export Views

Report ¥ Selected v Layouts ¥
Report Manager views
Process . PFMEA
- Header Data
o te: e Fnd
Y = e
v 4, 6077_Demo Seroe R T
IAG & VDA PFM - : - Show For Chid Processes
v &8 00005165 PrvotHead Asser{ | View: [ AJAG 8.YDAPFREA it |3 jfmens fegions sasinsind e
> 89 00005171 SR Dac Failure Analysis (Step 4) Risk Analysis (Step 5)
’ > #9 00005172 Install jaw latch
> # 00005173 Instal jaw pin Pms,’:,w- Revision Process Step Process kem ao"‘ o §E
> 29 00005174 Seaure latch to pf Falre Mode (FM) | Fare Cause (FC) Felne Effects §) CortrosPC)cf | 5% ig it
> #9 00005175 Secure the locking - . - v - - B ' - v -
powes s ot 1762 A B0 CNC Orill Holes in Foel / Air Fuel Hole Diameter 50 Diameter too bi S Oversize anll used- wrong arill 2 1 18
211900005126 ratal safety lock IES DrllingsC17:421 Manifold mm +/- 0.2 mm ’ selected
> #% 00005177 Instal locking bar (FN100)
= 17628 100.80 CNC Drill Holes in Fuel / Air Fuel Hole Diameter 50 Diameter too big 3 Oversize drill used - wrong drill 1 1 3
Collect 5th wheel| | 5 Drilling+C17:421 Manifold mm +- 0.2 mm select
& 00005166 Base Assembly (FN100)
s 3 1763 A Install Latch 10 Oversize drillfrom supplier 1 4
s s 5 1763 B Install Latch -A7 6 Oversize drill from supplier 2 4
Test 5 1764 A 10 CNC Spindle alignment error 2 5
6 1764 B 7 CNC Spindle alignment efror E 2 i
7 1765 A 10 Manifold loosein fixture T 2 20
8 1765 B 10 Manifold loose in fixture 2 2 e
1766 A Diameter too small 10 Undersize drill use - wrong drill 1 1 10
2 selected
1766 8 Diameter too small 5 Undersize drill use - wrong drill 1 1 5
0 selected
Kl
= —+

7] Consumption = Viewer Operationlist = Actwitylist = Propertes CustomField Meda Tme WorkStep Resource ModelOption = EditModel-Opion = Document —PFMEA  Control Plan

7.2 Show for child processes

a. Checking the ‘show for child processes’ displays the QA results of the selected process and all
its children. This function becomes handy when performing an overall detailed analysis of a
line.

b. In the example below, Routing is selected in the process tree and ‘show for child processes’ is
checked on the QA sheet, where all the QA related data tied to Routing, Operation and Activity

entity levels are displayed.

@ Assembly Planner - o x
File Edit Tools Help

O Back € Forwerd [

Home Process Consumption ‘CAD Viewer guahw Analysis Media o -
fE OB A S D v
b QAReport  QARevision Import Copy Remove Header | & Load Default Views
~ ComparsonReport~ = v Selected ¥ Layouts ¥
Report Manager Views ~
i Process = PFMEA
¥
erre—— nd Header Data L]
D Descriptior TMEA ID
¥ = ol Custo e
: LR 6077 _Demo
el - = I how For Chid I
AIAG & VDA PFMEA - 3 B - Merge Rows Sl For Processes
v 48 00005165 Pivot Head Ascer| | ™ Rtz Mo v £ e
> 9 00005171 Stick Decals Failure Analysis (Step 4) Risk Analysis (Step 5) A
> & 00005172 Install jow latch 5 5
2 > #® 00005173 Install jaw pin Status. Revaion Process Step Process em Curent o =
Prevention 2|
; > & 00005174 Seaure latch to pf Fakre Mode M) - ([SFehiee Cause () AR ControsfPC)of | £ SE e
i > B 0000175 Seaure theloden] = - = = = = = ~ I - = =
> & 00005176 Installsafety locd | 1 k) 6077 0 0 0
Operation AirHole :Noburs  Burrs present 8 None Drill speed oo 8 2 128
> # 00005177 Install locking barf | 2 P (FN106) slow
» & 00005178 Collect S5th wheel = B 100.80 CNC Drilling Drill Holes in Fuel / Ar Fuel Hole Dismeter 50 Diameter too big 10 | Drill pre-setter check before each | Oversize drill 1 0 10
= ~ 3 Manifold mm +- 0.2 mm Operations checks drill diameter  used - wrong
i 2| 00005166 Base Assembly | (FN100) Grill selected
=t r 8 10080 CNC Drill Holes in Fuel / Air Fuel Hole Diameter 50 Diameter tos bi 10 Oversizedrill used - wrong dill 2 3
i 3 coonsi67 frspecton 4 = Drilling+C17-421 Manifold mm +- 0.2 mm “ sel
48| 00005244 Test (FN100)
5 4 8 10 | Oversizedrill from supplier 1 ¢ .
6 | = B 10 CNC Spindle alignment error 2 5 -
7 = 8 10 Manifold loose in fcure 1 2 2
] - B Diameter too small 10 Urlgectr;ge drill use - wrong drill 1 1 10
9 o 0| Undersize drill from supplier 1 3 0
10 -] 10 Drill Wear 1 2 20 |~
[« ¥
-—t—+ =
. 3 Consumpton | Viewer ~Operaionlist = Activitylist = Properties = CustomFeld =~ Meda = Tme WoriStep | Resowrce | Model Option | EditModel-Option | Docsment =PFMEA  Control Plan
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c. The users can also filter the data for multi-selected processes from the process tree. The QA

module has the ability to display results based on selected processes.

7.3 Merge Rows

a. By checking the ‘Merge Rows,’ unique rows values on the sheet will be merged.

Note: This function is currently applicable only for entire sheets, individual cells cannot be merged.

PFMEA

Header Data

Vew: [ NAG &.1DA PPVEA -] Rovans Manege Fovens Show For CrldProceses | e
Failure Analysis (Step 4) Risk Analysis (Step 5)
= =
Status Revision Process Step Process tem N Current o QE
Prevention el
Failure Mode (FM) Failure Cause (FC) =0 Failure Effects (FE) Controls{PC) of =~ E RPN
FC ®
1 N B 6077 0 0 0
2 F ? Operation Air Hole : No burrs Burrs present 8 None Drill speed too 8 2 128
(FN106) slow
e 100.80 CNC Drilling Drill Holes in Fuel / Air Fuel Hole Diameter 50 Diameter too big 10 Drill pre-setter check beforeeach ~ Oversizednil 1 0 10
3 Manifold mm +- 0.2 mm Operations checks drill diameter used - wrong
(FN100) drill selected
- 100.80 CNC Oversize drill used - wrong dnill 2 3
- Drilling+C17:J21 selected
7.4 View

a. Users can create their own views, instead of using the default/ system generated views.

b. Right-click> Customize view on the sheet you wanted to copy from.

c. Select Add View at the top> Give an ID and Hit Ok.

d. Do the field customizations if any, and click Ok at the bottom. A new view for the specific user
will be created.

View

1 Cument View: AIAG & VDA PFMEA

Columns | Properties

Hidden Fields:

Name

P o Classification

i FilterCode

‘... CurrControlDetection

Add View

D: ||

=

z oo

TS VSO TV YISO T

ProcessStep

Width Key
90
72
132

e. On the QA sheet, View dropdown, the created sheet will be available for user to select and
work with. The user can work with any of the available views.
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PFMEA

Header Data

View: | AIAG & VDA PFMEA *| Revisions: |B - | Manage Revisions Merge Rows Show For Child Processes Filter
AIAG & VDA PFMEA
AIAG PFMEA 4th Edition Failure Analysis (Step 4)
Default i i B I | 5 |

7. 5 Load/ Export views

a. Load Default View: If the users modify their views and wish to reset to default view, with the

load default view function, users can easily get back to the default/ company specific view.

Home Process Consumption CAD Viewer Quality Analysis Media
4=] B E D& Bl s
QA Report QA Revision Import Copy Remove Header € Load Defauit Views
Comparison Report Selected Layouts

Report Manager Views

b. Export view: There are cases where the user wants to set up a specific QA standard view
throughout the plant. In this case, the user can set up the required view on their machine and
export the views.

Administrator functions to deploy the new set of views,
i. Apply customize view changes.
ii. Click export views which will save as ‘UserSettings.xml’ file.

iii. Rename the file as, ‘InitialViewSettings.xml’

iv. Upload the file to AP> Admin Tools> Template Manager> Configuration files.

V. Refresh the templates/ restart the application

vi. Now in the QA module, if any user clicks 'load default view,' the saved view will be
loaded.

Note: Provide the new ‘InitialViewSettings.xml’ file to ProPlanner support, to include

the views as part of standard deployment.

7.6 Import/ Copy

a. Import/ Copy function: Enables the user to load/ export the QA data from Worksteps to QA
sheets and from QA back to Worksteps. (Note: Templates need to be defined for this function
to work, contact ProPlanner support).

b. Remove Selected: Removes the selected QA data from the active sheet.
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Home Process Consumptiol CAD Viewer Quality Analysis Media
H B &0 &

QA Report QA Revision Import Copy Remove Header € Load Default Views
v Comparison Report V| v v Selected ¥  Layouts v

Report Manager Views

) Export Views

Cc. Header Layouts: Customize view for header layout.

7.7 Reports

Home Process Consumption CAD Viewer Quality Analysis Media

T B |80 @ [ e

A Report QA Revision Import Copy Remove Header € Load Default Views
v Comparison Report v v v Selected ¥  Layouts ¥
Report Manager Views

a. QA Standard Report: Basically, generates an excel report of what's displayed in the QA Sheet.
What You See Is What You Get (WYSIWYG).

o

P Search Sanjay Raj Thangavel

L Comments

File ~ Home Inset Draw Pagelayout Formulas Data  Review View Automate  Developer  Help
- o | =mm = AutoSum ~ e i
A cur Calibri v WA R EEz ¥ [Bweprex General . [EA @ @ &= = [H T,n un %? /O @‘
~ L]Fill ~
(B copy Ly = = Eleescener v | § v % 9 4 9 | Condional formatas Cell | nsert Delete Format ‘ Sort& Find& | Analyze
< Format Painter = = == 9 9 20 Eormatting  Table v Styles v B v - € Clear~ Filterv Select~  Data
Clipboard [} Fant [ Alignment [} Number [ Styles Cells. Editing Analysis | Sensitivity
116 - e
B c [ ‘ E F G H | | ) K L :
1 - Failure Analysis (Step 4) Risk Analysis [Step 5)
R E Ste P It
2 e i rocessttem | Failure Mode (FM) [ Failure Cause (FC) [Severity (S) of FE] Failure Effects (FE) | Current Prevention | Occurrence | Detection (D) |RPN|Pre
3 B 6077 0 0 "] o
4 B Operation Assembly 8 None 8 8 512
» Drill Holes in Fuel / Air  Fuel Hole Diameter 50 mm +/- . Drill pre-setter check before each Oversize drill used -
B 100.80 CNC Drill Diameter too b 9 1 1 9
5 riline Manifold 0.2 mm (FN100) lametertoo big Operations checks drill diameter wrong drill selected
100.80 CNC Drill Holes in Fuel / Air  Fuel Hole Diameter 50 mm +/-
Diameter too bi 9 Oversize drill used - dril selected 2 1 18
6 Drilling+C17:121 Manifold 0.2 mm (FN100} \ameter oo big versize ariflused -wrong arf selecte
7 B Install Latch 10 Oversize drill from supplier 1 4
8 B 10 CNC Spindle alignment error 2 5
9 B 10 Manifold loose in fixture 1 2 20
10 B Diameter too small 10 Undersize drill use - wrong drill selected 1 1 10
11 B 10 Undersize drill from supplier 1 3 30
12 8 10 Drill Wear 1 2 20
13

b. QA Revision Comparison Report: This report compares the selected two revisions and

highlights the changes/ adds/ deletes on the generated excel report. Green- Newly added;

Yellow- Edited/ change of content; Red- Content deleted.

Fle Home Insert Draw  Pagelayout Formulas Data Review View  Automate  Developer  Help I Comments 15 Sh

T ?c“‘ Calibr S A a | = 2o [BWap Tent General [ R @ @ 8 = i é“"'ws”“‘ i /C) ;i
“ [copy ~ Fill »
Paste o al|= B . cg @ Conditonal Formatas Cell | Insert Delete Format Sort& Find& | Anayze
~ RO romatraae ru . = Elmerge & center $ %9 WA Formatting ~ Table ~ Styles - - ~ & Claar ~ Filter ~ Select~ | Data
Clipboard 1 Font ] Alignment ] Number [} Styles Cells Editing Analysis | Sensitivity
121 - I3
c o E F [ H K L M
1 | Failure Analysis (Step 4) Risk Analysis (Step 5) |
Revision Process Step Pracess '“"'| Failure Mode (FM) | Failure Cause (FC) ‘sﬂemy (5) of FE Fallure Effects (FE) ‘Q':‘“"E"“{m Detection (D) of | ooy |Pnevev
of FC FC/FM
DriltHolesIn - Hole Diameter 50
s 100,80 CNC Drilling+€17:21 Fuel / Air Diameter too big 9 Oversize drill used - wrong dril selected 2 1 18
S Mot MM +/-0.2 mm (FN100)

8 (100.80 CNC Drilling+C17:121Install Latch (906 (Oversize drillused - wrong drill selected)Oversize drill 2 14 (18)a8
4 from supplier
s (aB _ (10)7 (Oversize drill from supplier)CNC Spindle alignment 1 (4)2 (40)14
6 B (6)10 (Oversize drill from supplier)Manifold loose in fixture 2 )2 (48)40
7 (100)5
8
9

(A)B Diameter teo small (10)5 (CNC Spindle alignment error)Undersize drill use - (21 5)1
8 (7)3 (CNC Spindle alignment error)Undersize drill from (1)2 (2)a (14)24

(A)B 10 (Manifold loose in fixture)Drill Wear 1 2 20
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